<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name='robots' content='index, follow, max-video-preview:-1, max-snippet:-1, max-image-preview:large' />

	<!-- This site is optimized with the Yoast SEO plugin v19.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>What You Need to Know About the Aug. 9 Primary Election in Milwaukee - Milwaukee Courier Weekly Newspaper</title>
	<link rel="canonical" href="https://milwaukeecourieronline.com/index.php/2022/07/23/what-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="What You Need to Know About the Aug. 9 Primary Election in Milwaukee - Milwaukee Courier Weekly Newspaper" />
	<meta property="og:description" content="By O. Ricardo Pimentel This story was originally published by Milwaukee Neighborhood News Service, where you can find other stories reporting on fifteen city neighborhoods in Milwaukee. Visit milwaukeenns.org. &nbsp; Residents will help choose their party’s nominees for such high-profile races as governor and the U.S. Senate on Tuesday, Aug. 9, with the Senate race in particular [&hellip;]" />
	<meta property="og:url" content="https://milwaukeecourieronline.com/index.php/2022/07/23/what-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee/" />
	<meta property="og:site_name" content="Milwaukee Courier Weekly Newspaper" />
	<meta property="article:publisher" content="https://www.facebook.com/milwaukeecourier/" />
	<meta property="article:published_time" content="2022-07-23T18:46:31+00:00" />
	<meta property="og:image" content="https://milwaukeecourieronline.com/wp-content/uploads/2022/07/voter-voting-at-poll-station.jpg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="450" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Courier Admin" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@milwcouriernews" />
	<meta name="twitter:site" content="@milwcouriernews" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Courier Admin" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="8 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Milwaukee Courier Weekly Newspaper &raquo; Feed" href="https://milwaukeecourieronline.com/index.php/feed/" />
<link rel="alternate" type="application/rss+xml" title="Milwaukee Courier Weekly Newspaper &raquo; Comments Feed" href="https://milwaukeecourieronline.com/index.php/comments/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.7.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-11416926-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/milwaukeecourieronline.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='news-pro-theme-css'  href='https://milwaukeecourieronline.com/wp-content/themes/news-pro/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.9.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.9.3/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.9.3/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.9.3/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/11.1.2/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/11.1.2/css/jetpack.css' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-tabs-stylesheet-css'  href='https://milwaukeecourieronline.com/wp-content/plugins/genesis-tabs/assets/css/style.css?ver=0.9.5' type='text/css' media='all' />
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.7.0' id='monsterinsights-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='monsterinsights-frontend-script-js-extra'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/milwaukeecourieronline.com","hash_tracking":"false","ua":"UA-11416926-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/themes/news-pro/js/responsive-menu.js?ver=1.0.0' id='news-responsive-menu-js'></script>
<link rel="https://api.w.org/" href="https://milwaukeecourieronline.com/index.php/wp-json/" /><link rel="alternate" type="application/json" href="https://milwaukeecourieronline.com/index.php/wp-json/wp/v2/posts/48413" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://milwaukeecourieronline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://milwaukeecourieronline.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.3" />
<link rel='shortlink' href='https://milwaukeecourieronline.com/?p=48413' />
<link rel="alternate" type="application/json+oembed" href="https://milwaukeecourieronline.com/index.php/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmilwaukeecourieronline.com%2Findex.php%2F2022%2F07%2F23%2Fwhat-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://milwaukeecourieronline.com/index.php/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmilwaukeecourieronline.com%2Findex.php%2F2022%2F07%2F23%2Fwhat-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.26 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-2 { margin:0px 0px 0px 0px;width:100%; max-width:125px; height:100%; max-height:125px; }
	.g-3 { margin:0px width:100%; max-width:720px; height:100%; max-height:90px; }
	.g-4 { margin:0px width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-5 { margin:0px;  width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-6 { margin:0px;  width:100%; max-width:728px; height:100%; max-height:90px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<style>img#wpstats{display:none}</style>
	<link rel="icon" href="https://milwaukeecourieronline.com/wp-content/themes/news-pro/images/favicon.ico" />
<style type="text/css">.site-title a { background: url(https://milwaukeecourieronline.com/wp-content/uploads/2015/04/milwaukee-courier-newspaper-you-can-trust-since-1964-logo.jpg) no-repeat !important; }</style>
			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<style id="sccss">/* Enter Your Custom CSS Here */
.top-ad-widget {
  margin: 0 auto;
	width: 1140px;
	height: 191px;
}

.inline-graphical-text {
  margin-bottom: 0px !important;
}
.ui-tabs-nav {
  display: none;
}
.genesis-nav-menu > .date, .genesis-nav-menu > .right > a {
  padding: 10px 24px;
}
.search-form {
    overflow: visible;
}
.genesis-nav-menu > .search {
    padding: 0px;
    padding-top: 10px;
    padding-right: 10px;
}
.genesis-nav-menu .search input {
    font-size: 12px;
    padding: 5px;
    position: relative;
    top: -5px;
}
.genesis-nav-menu .searchsubmit {
    display: none;
}
.sidebar-ads-top img, .sidebar-ads-bottom img {
   display: block;
   margin: 0 auto;
   margin-bottom: 20px;
}
.archive .entry-footer, .search-results .entry-footer {
  display: none;
}
.site-container {
  margin: 0px auto;
}
.site-header .wrap {
    padding: 0px;
}
.genesis-nav-menu a {
  padding: 10px 24px; 
}
.above-article {
  padding: 10px 40px; 
}
.archive .above-article, .search-results .above-article {
  display: none;
}
.entry-footer .entry-meta {
    border-top: none;
    padding: 12px 40px 8px;
}
.home .featuredpost article:last-child {
  margin-bottom: 0px;
  border-bottom: none;
}
.home #featured-post-3 h2 {
  width: 230px;
  float: right;
}
.home #featured-post-3 img {
  max-height: 65px;
  width: auto;
  float: left;
  margin-right: 20px;
  margin-bottom: 20px;
  max-width: 95px;
}

.archive img.fallback-image, .home #featured-post-4 img.fallback-image, .search-results img.fallback-image {
  max-height: 150px;
  width: auto;
  float: left;
  margin-right: 20px;
  margin-bottom: 20px;
}  
.home-top .widget.ui-tabs .entry h2 {
    margin: 0px;
    padding: 24px 24px 8px;
    position: absolute;
    bottom: 20px;
}
.home-top .widget.ui-tabs .entry h2 a {
    background: none repeat scroll 0% 0% rgba(0, 0, 0, 0.6);
}
/************ Related Posts *************/
.related-posts {
    overflow: hidden;
    margin: 0 0 10px;
}
 
.related-list li {
  list-style-type: none;
  margin: 0 10px 0 0;
  /* text-align: center; */
  display: block;
  min-height: 70px;
  padding-bottom: 10px;
}
 
.related-list img {
  /* border: 1px solid #000; */
  margin: 0 auto;
  display: block;
}
.related-image-thumb {
  width: 102px;
  float: left;
  display: block;
  margin-right: 10px;
}
.site-footer p {
  font-size: 10px;
  padding: 10px;
}
.site-footer {
  padding: 10px 0px;
}
.footer-widgets .textwidget {
  font-size: 13px;
}
.promo-smart {
  margin-bottom: 0px !important; 
}
.textwidget img {
  margin: 0 0 0 0;
}
/* END GLOBAL STUFF */

@media only screen and (max-width: 1188px) {
.title-area {
    float: none;
    padding-left: 0px;
    width: 300px;
    margin: 0px auto;
}
  .site-header .widget-area {
    float: none;
    padding-right: 0px;
    /* text-align: none; */
    width: 728px;
    margin: 0px auto;
}  
} /* END WIDTH 1188px */


@media only screen and (max-width: 1023px) {
  .genesis-nav-menu a, .genesis-nav-menu > .first > a, .genesis-nav-menu > .last > a {
    border: medium none;
    padding: 10px 12px;
  }  
.home-top .widget.ui-tabs .entry h2 {
    padding: 0px;
    position: static;
}  
} /* END WIDTH 1023px */


@media only screen and (max-width: 800px) {
   .site-header .widget-area {
      display: none; 
		/* width: 100%; */
    }
	.top-ad-widget {
  margin: 0 auto;
	width: auto;
	height: auto;
}
} /* END WIDTH 800px */


@media only screen and (max-width: 600px) {
  .footer-widgets, .footer-widgets .widget-title {
    text-align: center;
  }
  .site-container {
    width: 100%;
  }
} /* END WIDTH 600px */


@media only screen and (max-width: 360px) {
.entry {
    padding: 2px;
	}
} /* END WIDTH 360px */</style></head>
<body class="post-template-default single single-post postid-48413 single-format-standard custom-header header-image content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-visible"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.498039215686" /><feFuncG type="table" tableValues="0 0.498039215686" /><feFuncB type="table" tableValues="0 0.498039215686" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.549019607843 0.988235294118" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.717647058824 0.254901960784" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.278431372549" /><feFuncB type="table" tableValues="0.592156862745 0.278431372549" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.647058823529" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.780392156863 1" /><feFuncG type="table" tableValues="0 0.949019607843" /><feFuncB type="table" tableValues="0.352941176471 0.470588235294" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.650980392157 0.403921568627" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.447058823529 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.0980392156863 1" /><feFuncG type="table" tableValues="0 0.662745098039" /><feFuncB type="table" tableValues="0.847058823529 0.419607843137" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="site-container"><nav class="nav-secondary" aria-label="Secondary"><div class="wrap"><ul id="menu-main-top" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-40848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40848"><a href="https://milwaukeecourieronline.com/index.php/covid-19-resources/"><span >COVID-19 Resources</span></a></li>
<li id="menu-item-22069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22069"><a href="https://milwaukeecourieronline.com/index.php/about/"><span >About</span></a></li>
<li id="menu-item-22067" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22067"><a href="https://milwaukeecourieronline.com/index.php/subscribe-now/"><span >Subscribe</span></a></li>
<li id="menu-item-29762" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29762"><a href="https://milwaukeecourieronline.com/index.php/promotions/"><span >Promotions</span></a></li>
<li id="menu-item-22066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22066"><a href="https://milwaukeecourieronline.com/index.php/advertise-with-us/"><span >Advertise</span></a></li>
<li id="menu-item-22068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22068"><a href="https://milwaukeecourieronline.com/index.php/contact-us/"><span >Contact Us</span></a></li>
<li class="right search"><form method="get" class="searchform search-form" action="https://milwaukeecourieronline.com/index.php/search" >
<input type="text" value="Search this website" name="q" class="s search-input" onfocus="if (this.value == 'Search this website') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search this website';}" />
<input type="submit" class="searchsubmit search-submit" value="Search" />
</form></li><li class="right date">July 24, 2022</li></ul></div></nav><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://milwaukeecourieronline.com/">Milwaukee Courier Weekly Newspaper</a></p><p class="site-description">&quot;THE NEWSPAPER YOU CAN TRUST SINCE 1964&quot;</p></div><div class="widget-area header-widget-area"><section id="adrotate_widgets-42" class="widget-odd widget-last widget-first widget-1 widget adrotate_widgets"><div class="widget-wrap"><div class="g g-6"><div class="g-dyn a-94 c-1"><a class="gofollow" data-track="OTQsNiwxLDYw" href="https://www.gmar.com/" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2022/04/realtoirs-stand-for-strong-communities-greater-milwaukee-association-of-realtors-gmar-com.jpg"></a></div><div class="g-dyn a-69 c-2"><a class="gofollow" data-track="NjksNiwxLDYw" href="https://www.jpmorganchase.com/impact/people/advancing-black-pathways" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2021/04/Advancing-black-pathways-abp-Helping-Business-Owners-Thrive-jp-morgan-chase.jpg"></a></div><div class="g-dyn a-78 c-3"><a class="gofollow" data-track="NzgsNiwxLDYw" href="https://shermanpark.org/services/community-organizing/covid-vaccine-resources/" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2021/08/sherman-park-lets-get-back-to-who-what-we-love-responsibly-covid-vaccines.jpg"></a></div><div class="g-dyn a-79 c-4"><a class="gofollow" data-track="NzksNiwxLDYw" href="https://liberatemke.com" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2022/06/2022-LiberateMKE-police-cant-stop-reckless-driving.jpg"></a></div><div class="g-dyn a-74 c-5"><a class="gofollow" data-track="NzQsNiwxLDYw" href="https://www.hayatrx.com/" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2021/07/hayat-pharmacy-local-milwaukee-serving-community-like-no-one-else-for-10-years.jpg"></a></div><div class="g-dyn a-92 c-6"><a class="gofollow" data-track="OTIsNiwxLDYw" href="https://defendthesenate.org/" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2022/04/senate-republicans-tried-to-stop-her-we-must-defend-the-democratic-senate-wide-header.jpg"></a></div></div></div></section>
</div></div></header><nav class="nav-primary" aria-label="Main"><div class="wrap"><ul id="menu-main-categories" class="menu genesis-nav-menu menu-primary"><li id="menu-item-22071" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22071"><a href="https://milwaukeecourieronline.com/index.php/sections/news/"><span >News</span></a></li>
<li id="menu-item-22074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22074"><a href="https://milwaukeecourieronline.com/index.php/sections/editorials/"><span >Editorials</span></a></li>
<li id="menu-item-22075" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22075"><a href="https://milwaukeecourieronline.com/index.php/sections/education/"><span >Education</span></a></li>
<li id="menu-item-22078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22078"><a href="https://milwaukeecourieronline.com/index.php/sections/urban-business/"><span >Urban Business</span></a></li>
<li id="menu-item-22076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22076"><a href="https://milwaukeecourieronline.com/index.php/sections/health/"><span >Health</span></a></li>
<li id="menu-item-22077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22077"><a href="https://milwaukeecourieronline.com/index.php/sections/religion/"><span >Religion</span></a></li>
<li id="menu-item-22073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22073"><a href="https://milwaukeecourieronline.com/index.php/sections/upcoming-events/"><span >Upcoming Events</span></a></li>
<li id="menu-item-22072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22072"><a href="https://milwaukeecourieronline.com/index.php/sections/classifieds/"><span >Classifieds</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="above-article">

         
        </div> <article class="post-48413 post type-post status-publish format-standard has-post-thumbnail category-news tag-o-ricardo-pimentel tag-primary-election tag-u-s-senate-campaigns entry" aria-label="What You Need to Know About the Aug. 9 Primary Election in Milwaukee"><header class="entry-header"><h1 class="entry-title">What You Need to Know About the Aug. 9 Primary Election in Milwaukee</h1>
<p class="entry-meta"><time class="entry-time">July 23, 2022</time></p></header><div class="entry-content"><div id="attachment_48414" style="width: 810px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-48414" class="size-full wp-image-48414 jetpack-lazy-image" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/voter-voting-at-poll-station.jpg?resize=800%2C450&#038;ssl=1" alt width="800" height="450" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/voter-voting-at-poll-station.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/voter-voting-at-poll-station.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/voter-voting-at-poll-station.jpg?resize=768%2C432&amp;ssl=1 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/voter-voting-at-poll-station.jpg?resize=800%2C450&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" aria-describedby="caption-attachment-48414" class="size-full wp-image-48414" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/voter-voting-at-poll-station.jpg?resize=800%2C450&#038;ssl=1" alt="" width="800" height="450" srcset="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/voter-voting-at-poll-station.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/voter-voting-at-poll-station.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/voter-voting-at-poll-station.jpg?resize=768%2C432&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" data-recalc-dims="1"  /></noscript><p id="caption-attachment-48414" class="wp-caption-text">The fall primary election falls on Aug. 9 for Milwaukee. (NNS file photo by Andrea Waxman)</p></div>
<p><strong>By O. Ricardo Pimentel</strong></p>
<p><em>This story was originally published by Milwaukee Neighborhood News Service, where you can find other stories reporting on fifteen city neighborhoods in Milwaukee. Visit </em><a href="http://milwaukeenns.org/"><em>milwaukeenns.org</em></a><em>.</em><em> </em>&nbsp;</p>
<p>Residents will help choose their party’s nominees for such high-profile races as governor and the U.S. Senate on Tuesday, Aug. 9, with the Senate race in particular drawing national attention.</p>
<p>But voters will also determine which two candidates will advance to the November election to succeed Mayor Cavalier Johnson in Aldermanic District 2. This is a nonpartisan race.</p>
<p>And because no Republicans have filed to run for Milwaukee County sheriff, voters will choose among three candidates for that office.</p>
<p>Also on the ballot for local office: who will be the next Clerk of Circuit Court for Milwaukee County.</p>
<p>The last day to register to vote by mail and online is Wednesday, July 20.</p>
<p>The governor’s race and the U.S. Senate race have the highest profiles on the airwaves so far. Democrats have viewed GOP incumbent Ron Johnson as vulnerable and key to growing Democratic numbers in the Senate. Retired educator David Schroeder is also on the GOP ballot.</p>
<h4><strong>U.S. Senate race</strong></h4>
<p>Voters in the Democratic primary will choose who will challenge Johnson in the general election. The candidates are Lt. Gov. Mandela Barnes; Alex Lasry, senior vice president of the Milwaukee Bucks; Kou Lee, a restaurant owner; Sarah Godlewski, state treasurer; Peter Peckarsky, an attorney; Steven Olikara, entrepreneur and founder and former chief executive of the Millennial Action Project; Darrell Williams, administrator of the Division of Emergency Management in the Wisconsin Department of Military Affairs (on leave); &nbsp;and Tom Nelson, Outagamie County Executive.</p>
<p>The general election will be Nov. 8.</p>
<h4><strong>Race for governor</strong></h4>
<p>The governor’s race features incumbent Tony Evers on the Democratic side. Former Lt. Gov. Rebecca Kleefisch; construction business co-owner Tim Michels; State Rep. Timothy Ramthun; and real estate business owner Adam Fischer are running for the GOP nomination. Businessman Kevin Nicholson recently dropped out of the race.</p>
<p>In other statewide races, there are primary candidates on the ballot for lieutenant governor, attorney general, secretary of state and treasurer.</p>
<h4><strong>Milwaukee congressional and assembly races</strong></h4>
<p>In Milwaukee, there are also candidates on the ballot for Congressional District 4 and for state Assembly District 16.</p>
<p>The incumbent on the ballot in the congressional race is Democrat Gwen Moore. Tim Rogers and Travis Clark are the Republicans on the ballot for their party primary.</p>
<p>In Assembly District 16, Democratic incumbent Kalan Haywood is on the ballot. No one is on the ballot on the Republican side.</p>
<h4><strong>The race to succeed Mayor Johnson</strong></h4>
<p>Jerel Ballard, 27; Mark Chambers Jr., 35; and Keyellia “Kiki” Morries, 52, are vying for the District 2 seat formerly held by Mayor Johnson, who was elected in April.</p>
<p>(Another council seat is vacant following the departure of District 3 Ald. Nik Kovac, who was appointed budget director by Johnson. Democratic state Rep. Jonathan Brostoff is the only candidate and he will be on the November ballot.)</p>
<p><a href="https://www.jerelballard.com/news" target="_blank" rel="noopener"><strong>Ballard</strong></a>&nbsp;is a Milwaukee native and former television journalist. He is a Riverside University High School and Columbia College Chicago graduate. He was the communications and marketing officer for the Milwaukee Police Department and is currently communications director for the Public Service Commission of Wisconsin. He founded the Milwaukee’s Finest Scholarship Foundation. Ballard did not respond to requests for an interview.</p>
<p><a href="https://markchambersjr.com/" target="_blank" rel="noopener"><strong>Chambers</strong></a>&nbsp;is also a Milwaukee native, growing up in the Westlawn Projects section of District 2. He graduated from Bay View High School and attended Milwaukee Area Technical College. He worked in the financial sector and is now a business consultant for Community Related Training in Milwaukee.</p><!--Ad Injection:random-->
<div style='margin-top:3px;margin-bottom:3px;'><center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-0948874903250667"
     crossorigin="anonymous"></script>
<!-- 300x250, created 11/9/09 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-0948874903250667"
     data-ad-slot="5859996061"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
<p>Chambers said the most important issues for the city are gun violence and reckless driving.</p>
<p>“We’re in a crisis,” he said. “What separates me from the others is that I’ve lived through it personally.”</p>
<p>He said he lost his father to gun violence and a friend to reckless driving, adding that holding people with guns accountable will be key in addressing gun violence.</p>
<p><a href="https://www.kikiformilwaukee.com/" target="_blank" rel="noopener"><strong>Morries</strong></a>&nbsp;was born and raised in the 53212 ZIP code, which includes the Harambee neighborhood. She has a bachelor’s degree in criminal justice from Mount Senario College &nbsp;and a master’s degree in management from Cardinal Stritch University. She retired as a detective from the Milwaukee Police Department, having served 28 years, and now owns real estate companies.</p>
<p>Morries said the city’s most important issue is public safety.</p>
<p>“We have to first go to the core problem – working together with the police department to come up with those strategies,” she said. “They have things in place and we just need to implement them.”</p>
<p><a href="https://www.jsonline.com/story/news/politics/elections/2022/06/07/three-vie-milwaukee-council-seat-vacated-mayor-cavalier-johnson/7463511001/" target="_blank" rel="noopener"><strong>According to the Milwaukee Journal Sentinel,</strong></a>&nbsp;only Chambers currently lives in the district. Ballard and Morries will have to move into the district if elected.</p><!--Ad Injection:random-->
<div style='margin-top:3px;margin-bottom:3px;'><center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-0948874903250667"
     crossorigin="anonymous"></script>
<!-- 300x250, created 11/9/09 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-0948874903250667"
     data-ad-slot="5859996061"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
<p>But Morries said she has an apartment, where she gets her mail, and other properties in the district.</p>
<h4><strong>Sheriff’s race</strong></h4>
<p>The Democratic candidates for county sheriff are Denita Ball, Brian Barkow and Thomas Beal. No Republican has filed for the office, which means the primary could effectively decide the next sheriff.</p>
<p>All the candidates work in the Sheriff’s Department: Ball as chief deputy; Barkow as inspector and commander of the Investigative Services Bureau; and Beal is a sheriff’s captain.</p>
<h4><strong>Clerk of Circuit Court</strong></h4>
<p>The race for the Clerk of Circuit Court pits current Milwaukee County Clerk George Christenson, the incumbent because he was previously appointed as interim clerk of the court, against Anna Maria Hodges, the retired chief deputy clerk of the Circuit Court.</p>
<h4><strong>Steps to vote</strong></h4>
<p>To vote, you must register.</p>
<p>The City of Milwaukee has four ways you can complete or update your registration – by mail, online, at any Milwaukee Public Library or at your voting site on Election Day.</p>
<p>If you are uncertain of your registration status, name or address, you can go to&nbsp;<a href="https://myvote.wi.gov/en-us/"><strong>My Vote Wisconsin</strong></a>&nbsp;to look up your record.</p>
<p>Milwaukee residents can register by mail by downloading and printing the voter registration application found&nbsp;<a href="https://city.milwaukee.gov/ImageLibrary/Groups/electionAuthors/Documents/Users/Lauren-Berger/Voter-Reg-Packets/WEBSITERegistrationPackagewithPORInformation.pdf" target="_blank" rel="noopener"><strong>here</strong></a>.</p>
<p>You may then mail the application along with a copy of your proof of residence to:</p>
<p>City of Milwaukee Election Commission<br />
200 East Wells, Room 501<br />
Milwaukee, WI 53202</p>
<p><strong>Registrations by mail must be postmarked by Wednesday, July 20.</strong>&nbsp;If you miss the deadline, you can register to vote through the Friday of early voting or at your polling place on Election Day. Early voting will occur July 26 to Aug. &nbsp;6.</p>
<p>For a list of what constitutes proof of residence, go&nbsp;<a href="https://city.milwaukee.gov/election/Voter-Info/RegisterToVote" target="_blank" rel="noopener"><strong>here</strong></a>.</p><!--Ad Injection:random-->
<div style='margin-top:3px;margin-bottom:3px;'><center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-0948874903250667"
     crossorigin="anonymous"></script>
<!-- 300x250, created 11/9/09 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-0948874903250667"
     data-ad-slot="5859996061"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
<p>You can register online if you have a Wisconsin driver’s license or state identification card. Your address must be updated with the Division of Motor Vehicles. You can update your address free with the DMV&nbsp;<a href="https://wisconsindot.gov/Pages/online-srvcs/change-addy/default.aspx" target="_blank" rel="noopener"><strong>here</strong></a>. If there is a name change, you must do that in person at a DMV office.</p>
<p>Once your address and name are updated, go to&nbsp;<a href="https://myvote.wi.gov/en-us/Update-My-Name-or-Address" target="_blank" rel="noopener"><strong>MyVote</strong></a>&nbsp;to update your voter registration.</p>
<p>The Milwaukee Public Library sites to register in person are&nbsp;<a href="https://www.mpl.org/hours_locations/" target="_blank" rel="noopener"><strong>here</strong></a>.</p>
<p>To find your polling place to register on the day of the election, you can enter your address&nbsp;<a href="https://myvote.wi.gov/en-us/Find-My-Polling-Place" target="_blank" rel="noopener"><strong>here</strong></a>.</p>
<p>And to find a complete sample ballot, click&nbsp;<a href="https://myvote.wi.gov/en-us/Whats-On-My-Ballot" target="_blank" rel="noopener"><strong>here</strong></a>.</p>
<h4><strong>What you need to know about drop boxes</strong></h4>
<p>The Wisconsin Supreme Court injected a wrinkle into this election with a ruling July 8 that prohibits the use of unstaffed drop boxes and restricting absentee voters from using others to deliver their ballots.</p>
<p>The ruling was&nbsp;<a href="https://milwaukeenns.org/2022/06/28/advocates-for-voters-with-disabilities-express-angst-over-case-thats-before-wisconsin-supreme-court/" target="_blank" rel="noopener"><strong>decried by advocates for people with disabilities</strong></a>. In particular, the advocates are concerned about voters who don’t have the use of their arms and legs. They can have difficulty personally delivering ballots.</p>
<p>On Thursday, the Wisconsin Elections Commission Administrator, Meagan Wolfe, said voters have to place their own absentee ballots in the mail after the commission itself split on what advice to give the state’s election clerks following the Supreme Court ruling.</p>
<p>But Claire Woodall-Vogg, executive director of the City of Milwaukee Election Commission, said voters with disabilities are protected by federal law.</p>
<p>Though the City Attorney’s Office is still researching the ruling, Woodall-Vogg’s advice at the moment for voters with disabilities is that they can still have someone assist them in delivering their absentee ballots to mailboxes.</p>
<p>Unstaffed drop boxes will not be used in the Aug. 9 election, but voters can return their absentee ballots by mail, which must be received by Election Day. Moreover, absentee ballots can be delivered in person at early voting sites, which will be operating July 26 to Aug. 6.</p>
<p>These sites are: Midtown Center, 5700 W. Capitol Drive; Good Hope Library, 7717 W. Good Hope Rd.; Zablocki Library, 3501 W. Oklahoma Ave.; and Zeidler Municipal Building, 841 N. Broadway. The drop-off hours are weekdays, 9 a.m. to 6 p.m. and Saturdays and Sundays from 10 a.m. to 3 p.m.</p>
<p>And on the Monday before the election and on Election Day, voters can drop off their absentee ballots to the elections office in City Hall and staff will also be on hand to collect ballots on Market Street near City Hall.</p>
<p>Woodall-Vogg cautioned absentee voters to work ahead because mail can take two or three days to be delivered or up to a week in some cases.</p>
<p>For instructions on absentee voting in the city, go&nbsp;<a href="https://city.milwaukee.gov/election/Voter-Info/VotingbyAbsenteeBallot" target="_blank" rel="noopener"><strong>here</strong></a>.</p>
<p>Generally, the instructions caution that absentee voters should line up their witness before beginning the form and mark, seal, sign and return the ballot by Election Day.</p>
<p><em>(An earlier version of this story incorrectly stated the middle name of Anna Maria Hodges and her position. She is the retired chief deputy clerk of the Circuit Court).</em></p>
<p>Photo cap&nbsp; The fall primary election falls on Aug. 9 for Milwaukee. (NNS file photo by Andrea Waxman)</p>
<p>&nbsp;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share:</h3><div class="sd-content"><ul><li class="share-custom share-custom-facebook"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-facebook sd-button" href="https://milwaukeecourieronline.com/index.php/2022/07/23/what-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee/?share=custom-1422627478" target="_blank" title="Click to share on Facebook" ><span style="background-image:url(&quot;https://milwaukeecourieronline.com/wp-content/uploads/2015/01/facebook.png&quot;);">Facebook</span></a></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://milwaukeecourieronline.com/index.php/2022/07/23/what-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee/" data-text="What You Need to Know About the Aug. 9 Primary Election in Milwaukee"  >Tweet</a></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fmilwaukeecourieronline.com%2Findex.php%2F2022%2F07%2F23%2Fwhat-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee%2F&#038;media=https%3A%2F%2Fi0.wp.com%2Fmilwaukeecourieronline.com%2Fwp-content%2Fuploads%2F2022%2F07%2Fvoter-voting-at-poll-station.jpg%3Ffit%3D800%252C450%26ssl%3D1&#038;description=What%20You%20Need%20to%20Know%20About%20the%20Aug.%209%20Primary%20Election%20in%20Milwaukee" data-pin-do="buttonPin" data-pin-config="beside"><img src="https://i0.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img data-lazy-fallback="1" src="https://i0.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" data-recalc-dims="1"  /></noscript></a></div></li><li class="share-facebook"><div class="fb-share-button" data-href="https://milwaukeecourieronline.com/index.php/2022/07/23/what-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee/" data-layout="button_count"></div></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="mailto:?subject=%5BShared%20Post%5D%20What%20You%20Need%20to%20Know%20About%20the%20Aug.%209%20Primary%20Election%20in%20Milwaukee&body=https%3A%2F%2Fmilwaukeecourieronline.com%2Findex.php%2F2022%2F07%2F23%2Fwhat-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee%2F&share=email" target="_blank" title="Click to email a link to a friend" data-email-share-error-title="Do you have email set up?" data-email-share-error-text="If you&#039;re having problems sharing via email, you might not have email set up for your browser. You may need to create a new email yourself." data-email-share-nonce="d8a604d3cb" data-email-share-track-url="https://milwaukeecourieronline.com/index.php/2022/07/23/what-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee/?share=email"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://milwaukeecourieronline.com/index.php/2022/07/23/what-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee/#print" target="_blank" title="Click to print" ><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-tags">Popular Interests In This Article: <a href="https://milwaukeecourieronline.com/index.php/interests/o-ricardo-pimentel/" rel="tag">O. Ricardo Pimentel</a>, <a href="https://milwaukeecourieronline.com/index.php/interests/primary-election/" rel="tag">Primary Election</a>, <a href="https://milwaukeecourieronline.com/index.php/interests/u-s-senate-campaigns/" rel="tag">U.S. Senate Campaigns</a></span></p><div class="related-posts"><h3 class="related-title">Read More - Related Articles</h3><ul class="related-list"><li><a href="https://milwaukeecourieronline.com/index.php/2022/07/08/what-you-need-to-know-now-that-kids-can-get-vaccinated/" rel="bookmark" title="What You Need to Know Now That Kids Can Get Vaccinated"><div class="related-image-thumb"><img width="100" height="65" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/covid-vaccine-being-administered.jpg?resize=100%2C65&amp;ssl=1" class="attachment-related size-related jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/covid-vaccine-being-administered.jpg?resize=100%2C65&amp;ssl=1 100w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/covid-vaccine-being-administered.jpg?zoom=2&amp;resize=100%2C65&amp;ssl=1 200w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/covid-vaccine-being-administered.jpg?zoom=3&amp;resize=100%2C65&amp;ssl=1 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/07/covid-vaccine-being-administered.jpg?resize=100%2C65&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></div>What You Need to Know Now That Kids Can Get Vaccinated</a></li><li><a href="https://milwaukeecourieronline.com/index.php/2022/07/01/lasry-campaign-internal-poll-shows-primary-voters-believe-lasry-is-best-democrat-to-beat-ron-johnson/" rel="bookmark" title="Lasry Campaign Internal Poll Shows Primary Voters Believe Lasry Is Best Democrat To Beat Ron Johnson"><div class="related-image-thumb"><img width="100" height="65" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1" class="attachment-related size-related jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=283%2C180&amp;ssl=1 283w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1 100w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?zoom=2&amp;resize=100%2C65&amp;ssl=1 200w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></div>Lasry Campaign Internal Poll Shows Primary Voters Believe Lasry Is Best Democrat To Beat Ron Johnson</a></li><li><a href="https://milwaukeecourieronline.com/index.php/2022/06/03/ron-johnson-wont-protect-wisconsin-from-gun-violence-but-i-will/" rel="bookmark" title="Ron Johnson Won’t Protect Wisconsin From Gun Violence, But I Will"><div class="related-image-thumb"><img width="100" height="65" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1" class="attachment-related size-related jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=283%2C180&amp;ssl=1 283w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1 100w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?zoom=2&amp;resize=100%2C65&amp;ssl=1 200w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></div>Ron Johnson Won’t Protect Wisconsin From Gun Violence, But I Will</a></li><li><a href="https://milwaukeecourieronline.com/index.php/2022/06/01/new-poll-in-wi-senate-race-shows-alex-lasry-in-a-statistical-tie-with-mandela-barnes/" rel="bookmark" title="New Poll in WI Senate Race Shows Alex Lasry In a Statistical Tie With Mandela Barnes"><div class="related-image-thumb"><img width="100" height="65" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1" class="attachment-related size-related jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=283%2C180&amp;ssl=1 283w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1 100w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?zoom=2&amp;resize=100%2C65&amp;ssl=1 200w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></div>New Poll in WI Senate Race Shows Alex Lasry In a Statistical Tie With Mandela Barnes</a></li><li><a href="https://milwaukeecourieronline.com/index.php/2022/03/19/alex-lasry-blasts-sen-ron-johnson-for-failing-to-deliver-for-wisconsin-families-in-new-ad/" rel="bookmark" title="Alex Lasry Blasts Sen. Ron Johnson For ‘Failing To Deliver for Wisconsin Families’ In New Ad"><div class="related-image-thumb"><img width="100" height="65" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1" class="attachment-related size-related jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=283%2C180&amp;ssl=1 283w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1 100w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?zoom=2&amp;resize=100%2C65&amp;ssl=1 200w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2021/04/alex-lasry.jpg?resize=100%2C65&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></div>Alex Lasry Blasts Sen. Ron Johnson For ‘Failing To Deliver for Wisconsin Families’ In New Ad</a></li></ul></div></footer></article></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar"><section id="text-21" class="widget-odd widget-first widget-1 widget widget_text"><div class="widget-wrap">			<div class="textwidget"><h2 align="center"><a href="https://milwaukeecourieronline.com/index.php/covid-19-resources/" rel="noopener"><strong>View
COVID-19
Resources</strong></a></h2></div>
		</div></section>
<section id="media_image-4" class="widget-even widget-2 widget widget_media_image"><div class="widget-wrap"><a href="https://milwaukeecourieronline.com/wp-content/uploads/2022/06/milwaukee-courier-Grad-edition.pdf" target="_blank" rel="noopener"><img width="300" height="334" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/06/milwaukee-courier-Grad-edition.jpg?fit=300%2C334&amp;ssl=1" class="image wp-image-48157  attachment-full size-full jetpack-lazy-image" alt="" loading="lazy" style="max-width: 100%; height: auto;" data-lazy-srcset="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/06/milwaukee-courier-Grad-edition.jpg?w=300&amp;ssl=1 300w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/06/milwaukee-courier-Grad-edition.jpg?resize=269%2C300&amp;ssl=1 269w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/06/milwaukee-courier-Grad-edition.jpg?fit=300%2C334&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section>
<section id="adrotate_widgets-44" class="widget-odd widget-3 widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-98"><a class="gofollow" data-track="OTgsMCwxLDYw" href="http://Wiscaregiver.com/"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2022/07/earn-while-you-learn-500-dollar-bonus-get-started-wiscaregive-careers.jpg"></a></div></div></section>
<section id="adrotate_widgets-43" class="widget-even widget-4 widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-97"><a class="gofollow" data-track="OTcsMCwxLDYw" href="https://healthymke.com" target="_blank"><img src=https://milwaukeecourieronline.com/wp-content/uploads/2022/07/Facts-about-COVID-19-vaccines-djthebarber-tweet.jpg"></a></div></div></section>
<section id="adrotate_widgets-40" class="widget-odd widget-5 widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-91"><a class="gofollow" data-track="OTEsMCwxLDYw" href="https://www.860today.com/vaccine-information" target="_blank"><img src=https://milwaukeecourieronline.com/wp-content/uploads/2022/04/get-boosted-now-covid-vaccine-information.jpg"></a></div></div></section>
<section id="adrotate_widgets-38" class="widget-even widget-6 widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-90"><a class="gofollow" data-track="OTAsMCwxLDYw" href="https://milwaukeecourieronline.com/index.php/2022/03/18/blanket-of-love-dads-free-program-for-new-and-expectant-fathers-on-wednesdays-at-630pm/"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2022/03/blanket-of-love-dads-wednesdays-300-px.jpg"></a></div></div></section>
<section id="adrotate_widgets-39" class="widget-odd widget-7 widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-82"><a class="gofollow" data-track="ODIsMCwxLDYw" href="https://mam.org/cheret" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2022/07/always-new-posters-jules-cheret-on-view-now-milwaukee-art-museum.jpg"></a></div></div></section>
<section id="adrotate_widgets-37" class="widget-even widget-8 widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-88"><a class="gofollow" data-track="ODgsMCwxLDYw" href="https://www.jpmorganchase.com/impact/people/advancing-black-pathways" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2022/01/combating-the-racial-wealth-divide-jp-morgan-chase-and-co-learn-more.jpg"></a></div></div></section>
<section id="adrotate_widgets-36" class="widget-odd widget-9 widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-86"><a class="gofollow" data-track="ODYsMCwxLDYw" href="https://milwaukeecourieronline.com/index.php/2021/12/18/id-checks-protect-wisconsins-youth/"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2021/12/id-checks-protect-wisconsins-youth-banner.jpg"></a></div></div></section>
<section id="adrotate_widgets-29" class="widget-even widget-10 widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-72"><a class="gofollow" data-track="NzIsMCwxLDYw" href="http://healthymke.com" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2021/05/show-your-care-gwen-washington-covid-19-vaccine.jpg"></a></div></div></section>
<section id="media_image-3" class="widget-odd widget-11 widget widget_media_image"><div class="widget-wrap"><a href="https://milwaukeecourieronline.com/wp-content/uploads/2022/02/black-history-month-supplement-february-26-2022.pdf" target="_blank" rel="noopener"><img width="300" height="312" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/02/view-black-history-month-special-edition-black-future.jpg?fit=300%2C312&amp;ssl=1" class="image wp-image-46927  attachment-full size-full jetpack-lazy-image" alt="" loading="lazy" style="max-width: 100%; height: auto;" data-lazy-srcset="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/02/view-black-history-month-special-edition-black-future.jpg?w=300&amp;ssl=1 300w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/02/view-black-history-month-special-edition-black-future.jpg?resize=288%2C300&amp;ssl=1 288w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2022/02/view-black-history-month-special-edition-black-future.jpg?fit=300%2C312&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section>
<section id="media_image-2" class="widget-even widget-12 widget widget_media_image"><div class="widget-wrap"><a href="https://milwaukeecourieronline.com/wp-content/uploads/2020/12/covid-19-special-edition-revised.pdf" target="_blank" rel="noopener"><img width="300" height="273" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2020/11/view-covid-19-special-report-all-heroes-dont-wear-capes.jpg?fit=300%2C273&amp;ssl=1" class="image wp-image-43170  attachment-medium size-medium jetpack-lazy-image" alt="" loading="lazy" style="max-width: 100%; height: auto;" data-lazy-srcset="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2020/11/view-covid-19-special-report-all-heroes-dont-wear-capes.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2020/11/view-covid-19-special-report-all-heroes-dont-wear-capes.jpg?resize=300%2C273&amp;ssl=1 300w, https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2020/11/view-covid-19-special-report-all-heroes-dont-wear-capes.jpg?resize=768%2C700&amp;ssl=1 768w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2020/11/view-covid-19-special-report-all-heroes-dont-wear-capes.jpg?fit=300%2C273&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section>
<section id="adrotate_widgets-24" class="widget-odd widget-13 widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-56"><a class="gofollow" data-track="NTYsMCwxLDYw" href="https://uwcu.org" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2022/05/get-a-rate-youll-love-coming-home-to-uw-credit-union.jpg"></a></div></div></section>
<section id="adrotate_widgets-12" class="widget-even widget-14 widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-40"><a class="gofollow" data-track="NDAsMCwxLDYw" href="http://www.alz.org/wi" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2021/01/alzheimers-are-you-helping-an-aging-loved-one-friend-we-can-help.jpg"></a></div></div></section>
<section id="text-3" class="widget-odd widget-last widget-15 widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><a href="http://www.facebook.com/pages/Milwaukee-Courier/181767438520" target="_blank" rel="noopener">Become Our Fan On Facebook<br /><img src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2009/11/find_us_on_facebook_badge.gif?ssl=1" alt="Find Us On Facebook" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2009/11/find_us_on_facebook_badge.gif?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img data-lazy-fallback="1" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2009/11/find_us_on_facebook_badge.gif?ssl=1" alt='Find Us On Facebook' data-recalc-dims="1"  /></noscript></a><br /><br /><a href="http://www.twitter.com/milwcouriernews" target="_blank" rel="noopener">Follow Us On Twitter<br /><img src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2009/11/twitter-logo.jpg?ssl=1" alt="Follow Us On Twitter" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2009/11/twitter-logo.jpg?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img data-lazy-fallback="1" src="https://i0.wp.com/milwaukeecourieronline.com/wp-content/uploads/2009/11/twitter-logo.jpg?ssl=1" alt='Follow Us On Twitter' data-recalc-dims="1"  /></noscript></a></center></div>
		</div></section>
</aside></div></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="text-9" class="widget-odd widget-last widget-first widget-1 widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Editorials</h4>
			<div class="textwidget"><a href="https://milwaukeecourieronline.com/index.php/interests/lena-taylor/">Lena Taylor</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/lakeshia-n-myers/">Lakeshia Myers</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/jesse-jackson/">Rev Jesse Jackson Sr</a>
<a href="https://milwaukeecourieronline.com/index.php/interests/ashanti-hamilton/">Ashanti Hamilton</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="text-10" class="widget-odd widget-last widget-first widget-1 widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Journalists</h4>
			<div class="textwidget"><a href="https://milwaukeecourieronline.com/index.php/interests/mrinal-gokhale/">Mrinal Gokhale</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/dylan-deprey/">Dylan Deprey</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/karen-stokes/">Karen Stokes</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/hayley-crandall/">Hayley Crandall</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/ana-martinez-ortiz/">Ana Martinez-Ortiz</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="text-11" class="widget-odd widget-last widget-first widget-1 widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Topics</h4>
			<div class="textwidget"><a href="https://milwaukeecourieronline.com/index.php/sections/health/">Health Care & Wellness</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/climate-change/">Climate Change</a></br>
<a href="https://milwaukeecourieronline.com/index.php/sections/upcoming-events/">Upcoming Events<a/></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/obituaries/">Obituaries</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/milwaukee-naacp">Milwaukee NAACP</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-4 footer-widget-area"><section id="text-12" class="widget-odd widget-last widget-first widget-1 widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Politicians</h4>
			<div class="textwidget"><a href="https://milwaukeecourieronline.com/index.php/interests/president-barack-obama">Pres. Barack Obama</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/gwen-moore/">Gwen Moore<a/></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/tom-barrett/">Tom Barrett<a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/milele-coggs/">Milele A. Coggs</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/spencer-coggs/">Spencer Coggs</a></br></div>
		</div></section>
</div><div class="widget-area footer-widgets-5 footer-widget-area"><section id="text-13" class="widget-odd widget-last widget-first widget-1 widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Classifieds</h4>
			<div class="textwidget"><a href="https://milwaukeecourieronline.com/index.php/interests/job-openings/">Job Openings</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/bid-requests/">Bid Requests<a/></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/requests-for-proposals/">Req Proposals</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/requests-for-quotations/">Req Quotations</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/apartments-for-rent/">Apts For Rent</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-6 footer-widget-area"><section id="text-14" class="widget-odd widget-last widget-first widget-1 widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Contact Us</h4>
			<div class="textwidget">Milwaukee Courier</br>
2003 W. Capitol Dr.</br>
Milwaukee, WI 53206</br>
Ph: 414.449.4860</br>
Fax: 414.906.5383</div>
		</div></section>
</div></div></div><footer class="site-footer"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2022 &middot; Courier Communications | <a href="https://milwaukeecourieronline.com/index.php/privacy-policy/">View Privacy Policy</a> | Site built and maintained by Farrell Marketing Technology LLC<br />
We use third-party advertising companies to serve ads when you visit our   website. These companies may use information (not including your name, address,   email address, or telephone number) about your visits to this and other websites   in order to provide advertisements about goods and services of interest to you.   If you would like more information about this practice and to know your choices   about not having this information used by these companies, <a href="http://www.google.com/privacy_ads.html" target="_blank">click here</a>.</p></div></footer></div>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/milwaukeecourieronline.com\/index.php\/2022\/07\/23\/what-you-need-to-know-about-the-aug-9-primary-election-in-milwaukee\/":48413};
	</script>
							<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
								<script type="text/javascript">
				( function () {
					// Pinterest shared resources
					var s = document.createElement( 'script' );
					s.type = 'text/javascript';
					s.async = true;
					s.setAttribute( 'data-pin-hover', true );					s.src = window.location.protocol + '//assets.pinterest.com/js/pinit.js';
					var x = document.getElementsByTagName( 'script' )[ 0 ];
					x.parentNode.insertBefore(s, x);
					// if 'Pin it' button has 'counts' make container wider
					function init() {
						var shares = document.querySelectorAll( 'li.share-pinterest' );
						for ( var i = 0; i < shares.length; i++ ) {
							var share = shares[ i ];
							if ( share.querySelector( 'a span:visible' ) ) {
								share.style.width = '80px';
							}
						}
					}

					if ( document.readyState !== 'complete' ) {
						document.addEventListener( 'load', init );
					} else {
						init();
					}
				} )();
			</script>
					<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			document.body.addEventListener( 'is.post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
			<script type='text/javascript' src='https://c0.wp.com/p/jetpack/11.1.2/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='jshowoff-adrotate-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/milwaukeecourieronline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js' id='jshowoff-adrotate-js'></script>
<script type='text/javascript' id='clicktrack-adrotate-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/milwaukeecourieronline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js' id='clicktrack-adrotate-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/ui/tabs.min.js' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=83ec8aa758f883d6da14' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=54eb31dc971b63b49278' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/11.1.2/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script type="text/javascript">jQuery(document).ready(function($) { $(".ui-tabs").tabs(); });</script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({ groupid: 1, speed: 15000 });
	jQuery('.g-2').gslider({ groupid: 2, speed: 15000 });
	jQuery('.g-3').gslider({ groupid: 3, speed: 10000 });
	jQuery('.g-4').gslider({ groupid: 4, speed: 10000 });
	jQuery('.g-5').gslider({ groupid: 5, speed: 6000 });
	jQuery('.g-6').gslider({ groupid: 6, speed: 6000 });
}
});
</script>
<!-- /AdRotate JS -->

<script src='https://stats.wp.com/e-202229.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.1.2',blog:'83664269',post:'48413',tz:'-6',srv:'milwaukeecourieronline.com'} ]);
	_stq.push([ 'clickTrackerInit', '83664269', '48413' ]);
</script>
</body></html>
