<!DOCTYPE html>
<html lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>It’s Time…….</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Milwaukee Courier Weekly Newspaper &raquo; Feed" href="https://milwaukeecourieronline.com/index.php/feed/" />
<link rel="alternate" type="application/rss+xml" title="Milwaukee Courier Weekly Newspaper &raquo; Comments Feed" href="https://milwaukeecourieronline.com/index.php/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.3.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.3.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-11416926-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-11416926-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
<link rel='stylesheet' id='news-pro-theme-css'  href='https://milwaukeecourieronline.com/wp-content/themes/news-pro/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://milwaukeecourieronline.com/wp-includes/css/dashicons.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='sccss_style-css'  href='https://milwaukeecourieronline.com/?sccss=1&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://milwaukeecourieronline.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://milwaukeecourieronline.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-tabs-stylesheet-css'  href='https://milwaukeecourieronline.com/wp-content/plugins/genesis-tabs/style.css?ver=4.9.8' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/milwaukeecourieronline.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.3.2'></script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/themes/news-pro/js/responsive-menu.js?ver=1.0.0'></script>
<link rel='https://api.w.org/' href='https://milwaukeecourieronline.com/index.php/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://milwaukeecourieronline.com/xmlrpc.php?rsd" />
<link rel='prev' title='Riverside University High School Wins This Year’s 16th Annual MPS Battle of the Drumlines' href='https://milwaukeecourieronline.com/index.php/2018/12/15/riverside-university-high-school-wins-this-years-16th-annual-mps-battle-of-the-drumlines/' />
<link rel='next' title='Are the Walls Finally Closing in on Trump?' href='https://milwaukeecourieronline.com/index.php/2018/12/15/are-the-walls-finally-closing-in-on-trump/' />
<link rel='shortlink' href='https://milwaukeecourieronline.com/?p=36289' />
<link rel="alternate" type="application/json+oembed" href="https://milwaukeecourieronline.com/index.php/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmilwaukeecourieronline.com%2Findex.php%2F2018%2F12%2F15%2Fits-time%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://milwaukeecourieronline.com/index.php/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmilwaukeecourieronline.com%2Findex.php%2F2018%2F12%2F15%2Fits-time%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.13.4 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-2 { margin:0px;width:100%; max-width:125px; height:100%; max-height:125px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style><!-- <meta name="NextGEN" version="3.1.1" /> -->
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//milwaukeecourieronline.com/?wordfence_lh=1&hid=DCA1AEF19444100B4C1A487D52BF0FAB');
</script><style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://milwaukeecourieronline.com/wp-content/themes/news-pro/images/favicon.ico" />
<style type="text/css">.site-title a { background: url(https://milwaukeecourieronline.com/wp-content/uploads/2015/04/milwaukee-courier-newspaper-you-can-trust-since-1964-logo.jpg) no-repeat !important; }</style>
<meta property="og:title" content="It’s Time……." />
<meta property="og:site_name" content="Milwaukee Courier Weekly Newspaper" />
<meta property="og:description" content=""The President's Perspective"  By Alderman Ashanti Hamilton-Common Council President City of Milwaukee        For the length of my career as an elected offic..." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://milwaukeecourieronline.com/index.php/2018/12/15/its-time/" />
<meta property="og:image" content="https://milwaukeecourieronline.com/wp-content/uploads/2018/11/ashanti-hamilton.jpg" />
<meta property="fb:admins" content="1687009288" />
<meta property="fb:app_id" content="207692204288" />
<meta property="og:locale" content="en_US" />

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="It’s Time……." />
<meta property="og:url" content="https://milwaukeecourieronline.com/index.php/2018/12/15/its-time/" />
<meta property="og:description" content="&#8220;The President&#8217;s Perspective&#8221; By Alderman Ashanti Hamilton-Common Council President City of Milwaukee For the length of my career as an elected official, people have been asking m…" />
<meta property="article:published_time" content="2018-12-15T17:18:33+00:00" />
<meta property="article:modified_time" content="2018-12-15T17:18:33+00:00" />
<meta property="og:site_name" content="Milwaukee Courier Weekly Newspaper" />
<meta property="og:image" content="https://milwaukeecourieronline.com/wp-content/uploads/2018/11/ashanti-hamilton.jpg" />
<meta property="og:image:width" content="200" />
<meta property="og:image:height" content="301" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="It’s Time……." />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
</head>
<body class="post-template-default single single-post postid-36289 single-format-standard custom-header header-image content-sidebar" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-top" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-22070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-22070"><a href="https://milwaukeecourieronline.com" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-22069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22069"><a href="https://milwaukeecourieronline.com/index.php/about/" itemprop="url"><span itemprop="name">About</span></a></li>
<li id="menu-item-22067" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22067"><a href="https://milwaukeecourieronline.com/index.php/subscribe-now/" itemprop="url"><span itemprop="name">Subscribe</span></a></li>
<li id="menu-item-29762" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29762"><a href="https://milwaukeecourieronline.com/index.php/promotions/" itemprop="url"><span itemprop="name">Promotions</span></a></li>
<li id="menu-item-22066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22066"><a href="https://milwaukeecourieronline.com/index.php/advertise-with-us/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
<li id="menu-item-22068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22068"><a href="https://milwaukeecourieronline.com/index.php/contact-us/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li class="right search"><form method="get" class="searchform search-form" action="https://milwaukeecourieronline.com/index.php/search" >
<input type="text" value="Search this website &#x2026;" name="q" class="s search-input" onfocus="if (this.value == 'Search this website &#x2026;') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search this website &#x2026;';}" />
<input type="submit" class="searchsubmit search-submit" value="Search" />
</form></li><li class="right date">December 18, 2018</li></ul></div></nav><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://milwaukeecourieronline.com/">Milwaukee Courier Weekly Newspaper</a></p><p class="site-description" itemprop="description">&quot;THE NEWSPAPER YOU CAN TRUST SINCE 1964&quot;</p></div><div class="widget-area header-widget-area"><section id="adrotate_widgets-3" class="widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-21"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- top right wide -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-0948874903250667"
     data-ad-slot="9387953929"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></section>
</div></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-categories" class="menu genesis-nav-menu menu-primary"><li id="menu-item-22071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22071"><a href="https://milwaukeecourieronline.com/index.php/sections/news/" itemprop="url"><span itemprop="name">News</span></a></li>
<li id="menu-item-22074" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22074"><a href="https://milwaukeecourieronline.com/index.php/sections/editorials/" itemprop="url"><span itemprop="name">Editorials</span></a></li>
<li id="menu-item-22075" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22075"><a href="https://milwaukeecourieronline.com/index.php/sections/education/" itemprop="url"><span itemprop="name">Education</span></a></li>
<li id="menu-item-22078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22078"><a href="https://milwaukeecourieronline.com/index.php/sections/urban-business/" itemprop="url"><span itemprop="name">Urban Business</span></a></li>
<li id="menu-item-22076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22076"><a href="https://milwaukeecourieronline.com/index.php/sections/health/" itemprop="url"><span itemprop="name">Health</span></a></li>
<li id="menu-item-22077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22077"><a href="https://milwaukeecourieronline.com/index.php/sections/religion/" itemprop="url"><span itemprop="name">Religion</span></a></li>
<li id="menu-item-22073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22073"><a href="https://milwaukeecourieronline.com/index.php/sections/upcoming-events/" itemprop="url"><span itemprop="name">Upcoming Events</span></a></li>
<li id="menu-item-22072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22072"><a href="https://milwaukeecourieronline.com/index.php/sections/classifieds/" itemprop="url"><span itemprop="name">Classifieds</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="above-article">

         EXCEPT WHERE INDICATED, THE OPINIONS EXPRESSED ON THIS PAGE ARE NOT NECESSARILY THOSE OF THE MILWAUKEE COURIER<br />	

        
        </div> <article class="post-36289 post type-post status-publish format-standard has-post-thumbnail category-editorials tag-ashanti-hamilton tag-the-presidents-perspective entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">It’s Time…….</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2018-12-15T11:18:33+00:00">December 15, 2018</time></p></header><div class="entry-content" itemprop="text"><h2>&#8220;The President&#8217;s Perspective&#8221;</h2>
<p><strong>By Alderman Ashanti Hamilton-Common Council President City of Milwaukee</strong></p>
<div id="attachment_35855" style="width: 210px" class="wp-caption alignleft"><img class="size-full wp-image-35855" src="https://milwaukeecourieronline.com/wp-content/uploads/2018/11/ashanti-hamilton.jpg" alt="" width="200" height="301" srcset="https://milwaukeecourieronline.com/wp-content/uploads/2018/11/ashanti-hamilton.jpg 200w, https://milwaukeecourieronline.com/wp-content/uploads/2018/11/ashanti-hamilton-199x300.jpg 199w" sizes="(max-width: 200px) 100vw, 200px" /><p class="wp-caption-text">Common Council President<br />Ashanti Hamilton</p></div>
<p>For the length of my career as an elected official, people have been asking me when change is going to come to Milwaukee. When are things going to get better in their neighborhoods? When are people going to rise up and take ownership of their community? When are jobs going to come? The list goes on and on. My message for you today is simple—The time is now.</p>
<p>It is time for us to own the narrative surrounding our neighborhoods. No matter where you live, your neighborhood has a story. People that have been in the same house on the same block for 50 years don’t live there on accident. Long-time residents are the gatekeepers of our shared history. We need to learn that history, proclaim that history, take pride in that history and add our own chapter to that history. It’s time for residents to be proud of where they live.</p><!--Ad Injection:random-->
<div style='margin-top:3px;margin-bottom:3px;'><center><script type="text/javascript"><!--
google_ad_client = "pub-0948874903250667";
/* 300x250, created 11/9/09 */
google_ad_slot = "5859996061";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="https://pagead2.googlesyndication.com/pagead/show_ads.js">
</script></center></div>
<p>It is time for us to educate our children. During his most recent visit to City Hall, Governor-elect Evers pledged the support of his office to our children. We look forward to seeing more investments made in our schools, especially the institutions that serve our youngest and most vulnerable residents. As a matter of fact, the Governor Elect committed to a 5-Star Early Childhood Education right in the heart of the 53206 neighborhood. We will not stop until every single child has a place to go to get a foundation that will lead to a lifetime of success. It’s time for our youth to come to school already succeeding, not playing catch-up. It’s time for us as a community to collectively own and take on the responsibility of providing our children quality education and not point fingers at who is failing them. WE are failing them as a community.</p>
<p>It is time for violence in Milwaukee not just cease by end. We are losing precious lives left and right to senselessness. At the City-level, we must remain committed to making sure our efforts through MPD and OVP are reducing the violence in Milwaukee. As residents, we also need to do our part by teaching the value of someone’s life. No matter how different your circumstances are from someone else’s, we are united by the fact that we all only have one chance at life on Earth. One shot. Our existence is our most valuable resource. Nothing should take that away. It’s time to show the world that our lives have value and so do the lives of others.</p><!--Ad Injection:random-->
<div style='margin-top:3px;margin-bottom:3px;'><center><script type="text/javascript"><!--
google_ad_client = "pub-0948874903250667";
/* 300x250, created 11/9/09 */
google_ad_slot = "5859996061";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="https://pagead2.googlesyndication.com/pagead/show_ads.js">
</script></center></div>
<p>It is time for us to give people an opportunity. Neighborhoods across my District and every District in Milwaukee are filled with people who struggle to make ends meet. Some are unemployed; others work jobs that cannot sustain a family. Yet, employers are constantly saying that they are looking for employees. They have jobs that pay $15+/hour starting and cannot find people to take them. As a community, we need to make those opportunities known to those who need it. We have to do a better job communicating what’s out there. It is essential to deliver a message of hope, a message of a better life that people can achieve right now, today. It’s time to make that message real. Then let’s take it a step further than just the message. Let’s commit to actually doing something to connect the unemployed with employment.</p><!--Ad Injection:random-->
<div style='margin-top:3px;margin-bottom:3px;'><center><script type="text/javascript"><!--
google_ad_client = "pub-0948874903250667";
/* 300x250, created 11/9/09 */
google_ad_slot = "5859996061";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="https://pagead2.googlesyndication.com/pagead/show_ads.js">
</script></center></div>
<p>As I write this I am reminded that it has long been time for these things to happen in Milwaukee. People should have always had pride in their neighborhoods. We should have never let our schools get to a point where they were failing our students. Violence should never have become a description of our City. Opportunity should never have been something people dreamed of instead of seeing as tangible.</p>
<p>However, now is the moment where we must take up this call together. I truly believe that there has never been a better time to make this change happen. There is excitement about Milwaukee that I have never seen and felt before. Much of it is based in the opportunities that our challenges present. I believe this excitement has the potential to bring positive change to every corner of Milwaukee. We just have to be ready, willing and able to do the work. I believe we can be. It’s time!</p>
<!--Ad Injection:bottom-->
<div style='margin-top:3px;margin-bottom:3px;'><center>
</center></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share:</h3><div class="sd-content"><ul><li class="share-custom share-custom-facebook"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-facebook sd-button" href="https://milwaukeecourieronline.com/index.php/2018/12/15/its-time/?share=custom-1422627478" target="_blank" title="Click to share on Facebook"><span style="background-image:url(&quot;https://milwaukeecourieronline.com/wp-content/uploads/2015/01/facebook.png&quot;);">Facebook</span></a></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://milwaukeecourieronline.com/index.php/2018/12/15/its-time/" data-text="It’s Time……."  >Tweet</a></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="https://milwaukeecourieronline.com/index.php/2018/12/15/its-time/"></div></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fmilwaukeecourieronline.com%2Findex.php%2F2018%2F12%2F15%2Fits-time%2F&#038;media=https%3A%2F%2Fmilwaukeecourieronline.com%2Fwp-content%2Fuploads%2F2018%2F11%2Fashanti-hamilton.jpg&#038;description=It%E2%80%99s%20Time%E2%80%A6%E2%80%A6." data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-facebook"><div class="fb-share-button" data-href="https://milwaukeecourieronline.com/index.php/2018/12/15/its-time/" data-layout="button_count"></div></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://milwaukeecourieronline.com/index.php/2018/12/15/its-time/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-tags">Popular Interests In This Article: <a href="https://milwaukeecourieronline.com/index.php/interests/ashanti-hamilton/" rel="tag">Ashanti Hamilton</a>, <a href="https://milwaukeecourieronline.com/index.php/interests/the-presidents-perspective/" rel="tag">The Presidents Perspective</a></span></p><div class="related-posts"><h3 class="related-title">Read More - Related Articles</h3><ul class="related-list"><li><a href="https://milwaukeecourieronline.com/index.php/2018/12/08/got-democracy/" rel="bookmark" title="Got Democracy?"><div class="related-image-thumb"><img width="100" height="65" src="https://milwaukeecourieronline.com/wp-content/uploads/2018/11/ashanti-hamilton-100x65.jpg" class="attachment-related size-related" alt="" /></div>Got Democracy?</a></li><li><a href="https://milwaukeecourieronline.com/index.php/2018/12/01/common-council-passes-an-amended-2019-city-budget/" rel="bookmark" title="Common Council Passes an Amended 2019 City Budget"><div class="related-image-thumb"><img width="100" height="65" src="https://milwaukeecourieronline.com/wp-content/uploads/2018/11/ashanti-hamilton-100x65.jpg" class="attachment-related size-related" alt="" /></div>Common Council Passes an Amended 2019 City Budget</a></li><li><a href="https://milwaukeecourieronline.com/index.php/2018/11/24/thankful/" rel="bookmark" title="Thankful"><div class="related-image-thumb"><img width="100" height="65" src="https://milwaukeecourieronline.com/wp-content/uploads/2018/11/ashanti-hamilton-100x65.jpg" class="attachment-related size-related" alt="" /></div>Thankful</a></li><li><a href="https://milwaukeecourieronline.com/index.php/2018/11/17/what-have-you-done-for-you-lately/" rel="bookmark" title="What Have You Done for YOU Lately???"><div class="related-image-thumb"><img width="100" height="65" src="https://milwaukeecourieronline.com/wp-content/uploads/2018/11/ashanti-hamilton-100x65.jpg" class="attachment-related size-related" alt="" /></div>What Have You Done for YOU Lately???</a></li><li><a href="https://milwaukeecourieronline.com/index.php/2018/11/10/milwaukee-is-the-soul-of-wisconsin/" rel="bookmark" title="Milwaukee is the Soul of Wisconsin"><div class="related-image-thumb"><img width="100" height="65" src="https://milwaukeecourieronline.com/wp-content/uploads/2018/11/ashanti-hamilton-100x65.jpg" class="attachment-related size-related" alt="" /></div>Milwaukee is the Soul of Wisconsin</a></li></ul></div></footer></article></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="adrotate_widgets-5" class="widget adrotate_widgets"><div class="widget-wrap"><div class="a-single a-19"><a class="gofollow" data-track="MTksMCwxLDYw" href="https://thehopmke.com/" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2018/11/the-hop-open-for-business.gif" width="300" height="250"></a></div></div></section>
<section id="text-7" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div class="sidebar-ads-top"><a href="http://brainbrawnbody.com" target="_blank" rel="noopener"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2014/05/brain-brawn-body-ad.jpg" /></a></div></div>
		</div></section>
<section id="text-3" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Connect With Us</h4>
			<div class="textwidget"><center><a href="http://www.facebook.com/pages/Milwaukee-Courier/181767438520" target="_blank">Become Our Fan On Facebook<br /><img src="https://milwaukeecourieronline.com/wp-content/uploads/2009/11/find_us_on_facebook_badge.gif" alt='Find Us On Facebook' /></a><br /><br /><a href="http://www.twitter.com/milwcouriernews" target="_blank">Follow Us On Twitter<br /><img src="https://milwaukeecourieronline.com/wp-content/uploads/2009/11/twitter-logo.jpg" alt='Follow Us On Twitter' /></a></center></div>
		</div></section>
<section id="text-15" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div class="sidebar-ads-bottom">
<a href="http://wnov860.com/" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2015/08/wnov-860-am-the-voice-radio-logo.jpg" alt="WNOV 860 AM The Voice" width="300" height="107" border="0" /></a><a href="http://www.clean-as-a-whistle.com" target="_blank"><img src="https://milwaukeecourieronline.com/wp-content/uploads/2016/05/Clean-as-a-whistle-commercial-residential-new-construction-moving-cleaning-services.jpg" alt="Clean As A Whistle Commercial and Residential Cleaning Service" border="0" /></a>
</div></div>
		</div></section>
</aside></div></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="text-9" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Editorials</h4>
			<div class="textwidget"><a href="https://milwaukeecourieronline.com/index.php/interests/lena-taylor/">Lena Taylor</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/leon-d-young/">Leon D Young</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/jesse-jackson/">Rev Jesse Jackson Sr</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="text-10" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Journalists</h4>
			<div class="textwidget"><a href="https://milwaukeecourieronline.com/index.php/interests/mrinal-gokhale/">Mrinal Gokhale</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/dylan-deprey/">Dylan Deprey</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/karen-stokes/">Karen Stokes</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/nyesha-stone/">Nyesha Stone</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/ana-martinez-ortiz/">Ana Martinez-Ortiz</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/ethan-duran/">Ethan Duran</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="text-11" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Topics</h4>
			<div class="textwidget"><a href="https://milwaukeecourieronline.com/index.php/sections/health/">Health Care & Wellness</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/salvation-army/">Salvation Army</a></br>
<a href="https://milwaukeecourieronline.com/index.php/sections/upcoming-events/">Upcoming Events<a/></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/obituaries/">Obituaries</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/milwaukee-naacp">Milwaukee NAACP</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-4 footer-widget-area"><section id="text-12" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Politicians</h4>
			<div class="textwidget"><a href="https://milwaukeecourieronline.com/index.php/interests/president-barack-obama">Pres. Barack Obama</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/gwen-moore/">Gwen Moore<a/></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/tom-barrett/">Tom Barrett<a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/milele-coggs/">Milele A. Coggs</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/spencer-coggs/">Spencer Coggs</a></br></div>
		</div></section>
</div><div class="widget-area footer-widgets-5 footer-widget-area"><section id="text-13" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Classifieds</h4>
			<div class="textwidget"><a href="https://milwaukeecourieronline.com/index.php/interests/job-openings/">Job Openings</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/bid-requests/">Bid Requests<a/></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/requests-for-proposals/">Req Proposals</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/requests-for-quotations/">Req Quotations</a></br>
<a href="https://milwaukeecourieronline.com/index.php/interests/apartments-for-rent/">Apts For Rent</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-6 footer-widget-area"><section id="text-14" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Contact Us</h4>
			<div class="textwidget">Milwaukee Courier</br>
2003 W. Capitol Dr.</br>
Milwaukee, WI 53206</br>
Ph: 414.449.4860</br>
Fax: 414.906.5383</div>
		</div></section>
</div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2018 &middot; <a href="http://my.studiopress.com/themes/news/">News Pro Theme</a> On <a href="http://www.studiopress.com/">Genesis Framework</a> &middot; <a href="https://wordpress.org/">WordPress</a> &middot; <a href="https://milwaukeecourieronline.com/wp-login.php">Log in</a> | Site built by <a href="http://sproutingseedsoflove.com" target="_blank">Tony Farrell</a><br />
We use third-party advertising companies to serve ads when you visit our   website. These companies may use information (not including your name, address,   email address, or telephone number) about your visits to this and other websites   in order to provide advertisements about goods and services of interest to you.   If you would like more information about this practice and to know your choices   about not having this information used by these companies, <a href="http://www.google.com/privacy_ads.html" target="_blank">click here</a>.</p></div></footer></div><!-- ngg_resource_manager_marker -->
<!-- Infolinks START -->
<script type="text/javascript">jQuery(document).ready(function(){jQuery('.description').before('<span><!--INFOLINKS_OFF--></span>');jQuery('.description').after('<span><!--INFOLINKS_ON--></span>');jQuery('#headerimg').before('<span><!--INFOLINKS_OFF--></span>');jQuery('#headerimg').after('<span><!--INFOLINKS_ON--></span>');jQuery('h1').before('<span><!--INFOLINKS_OFF--></span>');jQuery('h1').after('<span><!--INFOLINKS_ON--></span>');jQuery('h1').before('<span><!--INFOLINKS_OFF--></span>');jQuery('h1').after('<span><!--INFOLINKS_ON--></span>');});</script>
<script type="text/javascript">
    var infolinks_pid = 257781; 
    var infolinks_plugin_version = "WP_3.2.2"; 
    var infolinks_resources = "//resources.infolinks.com/js"; 
</script>
<script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js" ></script>
<!-- Infolinks END -->
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/milwaukeecourieronline.com\/index.php\/2018\/12\/15\/its-time\/":36289};
	</script>
							<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
						<script>
			function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/platform.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );
			</script>
								<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
		<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
			<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/milwaukeecourieronline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/milwaukeecourieronline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201851'></script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://milwaukeecourieronline.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.8.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type="text/javascript">jQuery(document).ready(function($) { $(".ui-tabs").tabs(); });</script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({ groupid: 1, speed: 15000 });
	jQuery('.g-2').gslider({ groupid: 2, speed: 15000 });
}
});
</script>
<!-- /AdRotate JS -->

<script type='text/javascript' src='https://stats.wp.com/e-201851.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.1',blog:'83664269',post:'36289',tz:'-6',srv:'milwaukeecourieronline.com'} ]);
	_stq.push([ 'clickTrackerInit', '83664269', '36289' ]);
</script>
</body></html>

<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 1.15307093 sec
Time to load cache: 0.80404091
Cache file created on: 2018-12-18T18:02:23+00:00
Current time: 2018-12-18T23:14:13+00:00
-->